Java 1.5 in Netbeans in embedded Tomcat

  • Themenstarter Themenstarter Guest
  • Beginndatum Beginndatum
Status
Nicht offen für weitere Antworten.
G

Guest

Gast
Moin moin,

ich hab mich die letzten 2 Tage damit rumgeschlagen in meinem Netbeans 5.0 mein WebProjekt zum laufen zu bringen.
Jetzt hab ich das Problem gelöst und hier ist eine kleine Zusammenfassung:

Status:
Netbeans 5.0
embedded Tomcat 5.5
externer Tomcat 5.5
JDK 1.5
Windows XP Pro

Problem:
Ich habe ein WebProjekt das JSP Seiten enthält die 1.5 Goodies verwenden (generics, for-each Schleifen...).
Im externen Tomcat 5.5 kein Problem, im Tomcat 5.5 der bei Netbeans mit dabei war, trat folgender Fehler auf:

Code:
An error occurred at line: 15 in the jsp file: /page.jsp
Generated servlet error:
C:\Dokumente und Einstellungen\USER\.netbeans\5.0\jakarta-tomcat-5.5.9_base\work\Catalina\localhost\PRODUCT\org\apache\jsp\page_jsp.java:314: generics are not supported in -source 1.4
(try -source 1.5 to enable generics)
			List<Test> foo = bar.getTestList();

Der Fehler trat für alle 1.5 Goodies auf die ich verwendet habe.

Lösung:

in Netbeans -> Projects -> PRODUCT -> Configuration Files -> web.xml
-> Servlets

neuer Eintrag:
Servlet Name: jsp
Startup Order: 3 (sollte möglichst niedrig sein, da bin ich mir aber nicht 100% sicher)
Servlet Class: org.apache.jasper.servlet.JspServlet
Parameter (aus web.xml des Tomcat Home Dir im netbeans path):
fork = true
xpoweredBy = false
mappedfile = true

Parameter (neu):
compilerSourceVM = 1.5
compilerTargetVM = 1.5

-> Damit funktioniert es.
Die beiden neuen Parameter sagen dem embedded Tomcat (und auch sonst jedem) das für JSP Seiten Java 1.5 zu verwenden ist, gleichbedeutend zur Option '-source 1.5'

Ich hoffe es spart euch Arbeit.

Falls ihr die web.xml selber schreibt werft einen Blick hier hin:
http://blog.taragana.com/index.php/...enerics-enabled-and-other-15-only-features/2/

halof

Zo Phar

Der Mor
 
Nett... aber warum hast du den externen Tomcat nicht einfach als Server in Netbeans eingefügt? Dann entfallen die Konfigurations-Orgien für den internen Tomcat und den externen kannst du dennoch aus der IDE heraus starten, stoppen, etc.
 
Ziel war das ein neuer Mitarbeiter sich einfach nur NetBeans installiert, das Projekt aus dem CVS holt und anfangen kann.
Von daher war es sinnvoller alles bei Standarteinstellungen zu belassen.

Zo Phar

Der Mor
 
Status
Nicht offen für weitere Antworten.

Zurück
Oben