MySQL über Netzwerk --> Problem

Status
Nicht offen für weitere Antworten.

gondor

Bekanntes Mitglied
hallo!

ich habe auf meinem rechner im netzwerk (192.168.0.198) eine mysql-db laufen. über mein java-programm auf einen anderen rechner (192.168.0.197) würde ich gerne auf die mysql-db zugreifen. leider ist dieses nicht möglich 🙁 hier meine connection:

Code:
  /*Baut eine Verbindung zur MySQL auf und gibt bei Erfolg 'TRUE' zurück*/
  public boolean setConnectionMySQL () {

    boolean connection_open = false;

    try {

      //*** Treiber laden ***********************************
       Class.forName(dbDriver).newInstance();
       //*** Verbindung aufnehmen ****************************
        cn = DriverManager.getConnection(ip + user + passwd);

      if(cn != null) {
        connection_open = true;
        System.out.println("ArticCell_ConnectionDB --> setConnectionMySQL --> Create");
      }

    } catch(Exception ex) { /*do nothing*/}
    return connection_open;
  }

user: "root"
pass: ""
ip: "jdbc:mysql://192.168.0.198:3306/artic_cell?"

dbDriver: "com.mysql.jdbc.Driver";


wenn ich eine 'locale' db (befindet sich auf 192.168.0.197) anspreche ist das kein problem solange ich für die ip '127.0.0.1' angebe... doch über die ip 192.168.0.198 bzw. 192.168.0.197 geht das nicht.

hat einer rat?

gondor(..)
 
Hat der user "user" überhaupt die Berechtigung über das Netz auf die DB zu zugreifen?
Code:
grant all on mydb.* to user@"%" identified by ''
 
ah... das kanns sein. wo muss man denn die zeile eingeben?

unter sql meldet er fehler:

SQL-Befehl :

GRANT ALL ON mydb. * TO user@ "%"IDENTIFIED BY ''

MySQL meldet:

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '"%"IDENTIFIED BY ''' at line 1

kannst du mir noch einmal auf dir 'sprünge' helfen?

gondor(..)
 
sry, ein fehler hat sich eingeschlichen. der user ist: "root"

warum kann ich mich den mit "127.0.0.1" connecten aber mit "192.168.0.190" nicht? versteh ich nicht... 🙁

please help.

gondor(..)
 
Ich benutze für sowas Mysqlcc
Anstatt mydb mußt du natürlich den Namen deiner Datenbak eintragen also
Code:
grant all on artic_cell.* to user@"%" identified by
Danach kann der User "user",mit allen Rechten und von jedem beliebigen Host aus auf die DB zugreifen.
Mysql Doku
 
nun gut... ich habe rechte für 'root' verteilt:

Benutzer | Host | Kennwort | Globale Rechte | Grant

root | 192.168.0.190 | Nein | ALL PRIVILEGES | Ja

doch gibt es keinen erfolg zu buchen 🙁

muss ich mysql evtl. sagen, auf welche ip die db laufen soll? konnte keine einstellungen finden...

gondor(..)
 
jo, das musste machen 😉
wieso nimmst du nicht ganz einfach die mysql tools? das mysql adminstrator ist super 😉

aber eigentlich müsste foobars befehl funktionieren da er dir user@ freigibt

gib mal user@deinip oder user@localhost frei
 
ich habe jetzt folgende user freigegeben (mit allen privelegien)

root %
root 192.168.0.190
root localhost

doch nichts zu machen. ärgerlich... benutze nun auch das mysqlcc.

noch ratschläge vorhanden?

gondor(..)
 
gib mal net root frei sondern einen anderen user und saug dir mysql admin 😉 (ist von mysql und super)!
 
so, hab mal als user 'admin' erstellt. auch mit allen rechten...

... doch scheint das auch nicht der fehler zu sein.

mit mysql admin hantiere ich eigentlich schon von anfang an mit 😉

gondor(..)
 
ok, jungs!

problem gelöst. was hab ich gemacht?

hm... es lag einfach wohl an mein mysql. nochmal neu installiert, rechte vergeben und schwups, löp dat 😉

danke für eure (thE_29+foobar) hilfe!

gondor(..)
 
Status
Nicht offen für weitere Antworten.

Zurück
Oben